Quantcast Sony VAIO no sound via HDMI from laptop to TV

Closed Thread
Results 1 to 8 of 8
  1. #1
    Newbie
    Join Date
    Aug 2010
    Posts
    4
    Rep Power
    0

    Default Sony VAIO no sound via HDMI from laptop to TV

    I have recently purchased my new VAIO and I love it. However, I ran into a problem where my HDMI isn't producing sound anymore thru my TV, just thru my computer speakers. When it was working I went into my sound setting thru the control panel and set my default to the HDMI and it worked perfectly. For some reason now when my laptop is plugged into my TV it displays the picture, but no sound, and when I go to set it to default, the HDMI option isn't even available anymore. (probably because I had a couple drinks and somehow hit a delete button and now it's gone) Now I don't know what to do. I have read several forums and havent found one thing that will help me. If anyone can lead me in the right direction I would greatly appreciate it. THANKS!!

  2. #2
    Notebook Deity
    Join Date
    Apr 2009
    Posts
    727
    Rep Power
    16

    Default Re: Sony VAIO no sound via HDMI from laptop to TV

    - Try going into WMP.
    - Go to TOOLS (at the top), and click on OPTIONS.
    - Click on the DEVICES tab at the top, and you should see SPEAKERS in that list. Click and click on PROPERTIES.
    - A window pops up. Under SOUND PLAYBACK, there is a drop-down list. Provided your graphics and audio drivers are intact / active, you should be able to see an HDMI output in that list. Choose it, and click OK.

    I had to use the above steps when I first clean-installed W7. The OS didn't automatically change the sound settings when connecting via HDMI, but after the above it changes automatically.

    Yes, I know that the above is done in WMP, but that enabled the sound for the whole OS while connected on HDMI (including media playback).

    Let us know how it goes.
    VGN-Z26: C2D P8600 (2.4GHz), 8GB DDR3 RAM, 320GB Hitachi 7200RPM HDD, BD-RE drive, Hybrid nVidia / Intel graphics, Intel WifiLink 5100AGN, W7 Pro x64
    Battery drain fix-request thread
    http://forum.notebookreview.com/sony/423924-sony-battery-drain-fix-request-thread.html

  3. #3
    Newbie
    Join Date
    Aug 2010
    Posts
    4
    Rep Power
    0

    Default Re: Sony VAIO no sound via HDMI from laptop to TV

    I did that and when I tried to select the audio HDMI there was no option for it. Do I need to unplug my HDMI from TV and computer and try rebooting the computer? Thanks again

  4. #4
    Notebook Deity
    Join Date
    Apr 2009
    Posts
    727
    Rep Power
    16

    Default Re: Sony VAIO no sound via HDMI from laptop to TV

    Hmm... That is strange.
    Ok; when you plug in the HDMI cable to first the TV then the lappie, do you hear the 'device connected' tone from Windows? (that sound that Windows plays when you connect a flash drive for example)

    Also, try going to Device Manager and seeing whether the computer recognises the LCD TV.
    - START, right click COMPUTER and choose PROPERTIES
    - On the left side of the window that pops up, click on DEVICE MANAGER
    - Another window comes up.
    - Click on monitors and you should see your LCD TV.

    If not... You said that the HDMI connection was working properly only a while ago. Can I ask what laptop you have? If you have the Z series, you MUST be on the nVidia (SPEED) card for HDMI to work properly.

    Another bunch of steps you can try, just incase. Do these with the HDMI cable ATTACHED to your TV.
    - Go to CONTROL PANEL, and click on HARDWARE AND SOUND
    - Click on MANAGE AUDIO DEVICES under the SOUND heading.
    - In the small window that comes up, you should see the sound devices currently active at the moment.
    - Right-click the white space right under SPEAKER (or whatever the speaker is called on your machine).
    - Tick SHOW DISABLED DEVICES and SHOW DISCONNECTED DEVICES.
    - If you tick both and it reveals a device, turn that device on (or make it default etc etc) and check your sound.

    If THAT doesn't work, leave the connection connected and reboot.

    ...And if that doesn't work, are you sure your HDMI connection on either the lappie and TV are fully functional?

    ...And if all that fails, restore your machine back to the factory state and try again.

    ...And if that doesn't work, you might have some sort of faulty hardware (though unlikely from what you are saying; the problem probably is a negatively tweaked setting somewhere).

    Hopefully one of the above will solve your problem..... Again, let us know how things go.
    VGN-Z26: C2D P8600 (2.4GHz), 8GB DDR3 RAM, 320GB Hitachi 7200RPM HDD, BD-RE drive, Hybrid nVidia / Intel graphics, Intel WifiLink 5100AGN, W7 Pro x64
    Battery drain fix-request thread
    http://forum.notebookreview.com/showthread.php?t=423924

  5. #5
    308 Negra Arroyo Lane
    Join Date
    Nov 2007
    Posts
    3,037
    Rep Power
    35

    Default Re: Sony VAIO no sound via HDMI from laptop to TV

    If there are updated video drivers for your model or if you'd like to try LaptopVideo2Go's drivers, that usually fixes a LOAD of issues with HDMI.
    H * π

    There's always a flaw in the system. Finding it is the fun part. Exposing it is the dangerous part. Utilizing it is the human part.

  6. #6
    Notebook Enthusiast
    Join Date
    Aug 2010
    Location
    South Africa
    Posts
    29
    Rep Power
    11

    Default Re: Sony VAIO no sound via HDMI from laptop to TV

    I have a 1 week old F12

    And a cheap HDMI cable

    Plug in Cable on Samsung 1080p screen - Samsung changes to HDMI 3 and shows my desktop in 1080p

    1) Sony changed the resolution within about 10 secs so whole screen was vissbible - initially it was cutting of the sides.
    2) Fired up File on Windows Media Player
    3) Watched movie

    Could not have been easier. I love my F12 (and My Samsung C530 screen)

    PS - I downloaded the newest Nvidia drivers from nvidia.com when I did the clean install
    Last edited by jasweb; 24th August 2010 at 08:46 AM. Reason: Update

  7. #7
    Newbie
    Join Date
    Aug 2010
    Posts
    4
    Rep Power
    0

    Default Re: Sony VAIO no sound via HDMI from laptop to TV

    Ok well when I check for the device how you said to 5ushi I don't see my LCD TV. It just says Generic PnP Monitor but it says that twice. However when I go to control panel, view devices and printers, it is there. I have the VAIO V-series (VGN-FW####) When I plug the HDMI into my computer from my TV the laptop recognizes it and plays the little tune. I have no clue what to do anymore. I just wanna watch movies!!!!! LOL Thanks for helping once again!

  8. #8
    Newbie
    Join Date
    Aug 2010
    Posts
    4
    Rep Power
    0

    Default Re: Sony VAIO no sound via HDMI from laptop to TV

    I figured it out and I am very ecstatic about it HAHA. I clicked start then control panel and then view devices and printers. After this I right clicked on Sony TV and then properties. Then I clicked the Hardware tab then properties again. Then I clicked on change settings and then the Driver tab again. This is like a run on sentence at it's best but I just uninstalled that and unplugged my HDMI cable, rebooted and once the computer loaded up I plugged the HDMI back in and set the sound source default to HDMI. It worked. YAY!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 06:18 AM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1