Quantcast Windows 7 on Vaio Z - Procedure - Page 29

Closed Thread
Page 29 of 30 FirstFirst ... 19252627282930 LastLast
Results 281 to 290 of 299
  1. #281
    ccl
    ccl is offline
    Newbie
    Join Date
    Feb 2010
    Posts
    1
    Rep Power
    0

    Default Re: Windows 7 on Vaio Z - Procedure

    I have a VAIO ZX51, Win 7 64 bit Pro and to get the Qualcomm Gobi and bundled Orange Internet Everywhere working, I have to REPEATEDLY:

    • Reload WWAN driver, and
    • Then reload WWAN Manager (Orange)


    From VAIO Recovery - with a reboot of course! Otherwise, I get a crash from the Orange S/W

    Guess it is something to do with the Gobi - any ideas?

    Thanks!

    Chris

  2. #282
    gos
    gos is offline
    Newbie
    Join Date
    Mar 2010
    Posts
    1
    Rep Power
    0

    Default Re: Windows 7 on Vaio Z - Procedure

    Hi!

    I am trying to install 7 64 bit on my VGN-Z11XN/B!

    after install, I tried your guidelines but nothing seems to work.

    No FN keys, no S1, S2 keys functioning and no STAMINA/SPEED either.

    could you please help a bit

    thank you

    george

    Quote Originally Posted by pplive View Post
    Just finished installing Win7 on Z11XN with SSD. The positive thing is its a lot faster than Vista. The negatives:
    -Speed mode does not work, I accidentally allowed win to update Nvidia drivers before installing the originals..
    -Fn+brightness doesn't work even with stamina, UAC disabled
    -Fn+hibernate doesn't work
    -Vaio smartnetwork is somehow weird.. (completely blank, does not display the icons like BT, WLAN) however, WLAN works.
    -Alot of stuff missing..I only have Vaio Control Center in the programs menu (i think there used to be at least 5 other vaio programs..), and in the control center, I can only see system information and network connections...
    -unknown device: Intel(R) ICH9M-E LPC Interface Controller..
    -S1, S2 doesn't work

    Any ideas how to get the Fn-keys to work? The audio Fn keys do work.

    EDIT:

    I downloaded the Z utilities from Sony Z series 32bit Vista Clean Install Guide (full functions & no windows activation) as someone else had pointed it out previously.

    Finally the unknown device got drivers.. it was the Sony extension parser. Weird how this is not included in Sony driver support page for this model. Anyways, now everything started to work (s1,s2,fn-keys, stamina/speed switch), EXCEPT for the brightness fn keys on speed-mode. I guess thats the same for almost everyone.

  3. #283
    Newbie
    Join Date
    Apr 2010
    Posts
    2
    Rep Power
    0

    Default Re: Windows 7 on Vaio Z - Procedure

    For those of you struggling to get your WWAN working, as I was (to the point of almost giving up), I'll explain here the method I used and try to be as verbose as I can to make it as easy to understand as possible. I followed the instructions of someone else, but am just reproducing them here with a few extra bits I think that might help.

    I am carrying out this procedure on a Vaio VGN-Z31MN, on a fresh Windows 7, 64bit install. The instructions I'm basing this on were for a Vaio VHN-P19WN, so it is my guess that they will work equally well for most relatively modern Vaio's. As a bonus, it also made the S1, S2 and eject buttons work correctly, and all the brightness buttons and power saving stuff.

    The instructions I follwed didnt mention if the other guy was doing this for 32 or 64 bit, and the downloads don't indicate one or the other. So this may work equally well for 32bit.

    Firstly, I would advise you to create a system restore point before starting this method, so if you do something wrong you can roll back to it and have a very good chance of getting it working on the next attempt.

    The drivers you need to download are detailed below, I downloaded them all before starting so I had them ready to go. Again, I want to point out that I followed the instructions of someone who did this on a different model, so its probably not that important to worry about looking for the downloads for your specific model on the sony support site - just download the ones I have linked to below. There may or may not be newer versions of each of these - I didn't even bother to look - all I know is that this worked.

    1. Sony Shared Library 5.3
    ftp://ftp.vaio-link.com/pub/Vaio/Ori....3.0.11240.zip

    2. VAIO Setting Utility Series 4.3
    ftp://ftp.vaio-link.com/pub/Vaio/Ori....3.0.14120.zip

    3. VAIO Control Center 3.3
    ftp://ftp.vaio-link.com/pub/Vaio/Ori....3.0.12240.zip

    4. VAIO Event Service 4.3
    ftp://ftp.vaio-link.com/pub/Vaio/Ori....3.0.13190.zip

    5. Sony Firmware Extension Parser 8.0
    ftp://ftp.vaio-link.com/pub/Vaio/Ori..._O_8.0.0.1.zip

    6. VAIO Power Management 3.3
    ftp://ftp.vaio-link.com/pub/Vaio/Ori....3.0.12190.zip

    7. VAIO Smart Network 2.3
    ftp://ftp.vaio-link.com/pub/Vaio/Ori....3.0.12210.zip

    Once you have them all downloaded and unzipped, you're ready to proceed. Its important you install each of these in the order I have given them above. I renamed the folders I unzipped each of these downloads into to start with a number just to remind me the order in which I had to work through them.

    For each of the above downloads, just run the setup or install file in its directory before moving on to the next one. Some of the setup's will say to restart your computer when they have finished - so DO restart before moving onto the next installer. If they don't mention restarting, then just move on.

    Important to note, that #5 (Sony Firmware Extension Parser 8.0) doesn't have an installer or setup file. What you have to do for this one is go to your device manager and you should see an Unknown Device. Choose to update the driver for this, and when it asks, select to manually look for the driver in a location you choose - you should point out the directory you unzipped this to. It should find what it needs to and install the driver for this. Once its done, you should have an entry in device manager for Sony Firmware Extension Parser under the Human Interface Devices branch. I will also point out here that when I went to do this step, I had 2 entries for Unknown Device - if you do to, try it on each of them until it works on one of them. When #5 is done, do #6 and #7.

    When this is all done and you have rebooted, you should see the Sony Smart Network window on your desktop, working. If its not already enabled, you should be able to enable the WWAN device from here. I want to point out that if i put my laptop to sleep then re-wake it - I cannot re-enable the WWAN device without restarting the laptop. I can live with this.

    At this point, I had a (?) entry in device manager for Qualcomm HS-USB which the next bits will resolve. I now created another system restore point so I could revert to this stage if I messed the next bits up.

    Ok, once you have been able to enable the WWAN device you can install the WWAN driver and connection manager. These 2 things, I downlaoded from the sony support site, from the page for my specific model. If you can find them on a page for your model then best download those, else you might be able to get away with just downloading the same ones I did. In any case, this is what I downloaded:

    WWAN Driver
    http://support.vaio.sony.eu/computin...&m=VGN-Z31MN_B

    WWAN Connection Manager
    http://support.vaio.sony.eu/computin...&m=VGN-Z31MN_B


    To install the two things above, I had to go into control panel and disable User Account Control (You can re-enable it once these 2 things are installed). I originally tried to install these without disabling UAC a few times, but it never worked - I always still had that Qualcomm HS-USB thing showing in device manager (or it would just change to COM6 or COM7 etc), so I was glad I had made that system restore point earlier. To disable UAC, go to Control Panel -> User Accounts and Family Safety -> User Accounts -> Change User Account Control Settings and slide the slider all the way down. If I remember correctly, it prompted me to restart - so restart before installing the WWAN driver and WWAN connection manager.

    If you followed all the above steps correctly, you should now have it all functioning.

    TIP: I never ever used system restore points before, but from doing this i strongly suggest you do.

    TIP: A little while later, my Sony Smart Network thing disapeared and i couldnt re-enable the WWAN device. Somehow some of its program files vanished - just reinstall the Sony Smart Network thing from above, and all was fine again.


    Thanks to the poster of these instructions
    Last edited by mailslat; 7th April 2010 at 06:12 AM. Reason: added link to instructions i based this on

  4. #284
    Notebook Enthusiast
    Join Date
    Jun 2007
    Posts
    12
    Rep Power
    18

    Default Re: Windows 7 on Vaio Z - Procedure

    i have a vgn-z590 (us model) here. which euro model does it correspond to? VGN-Z5 as well?

    is there anywhere an up-to-date windows 7 description? the first post contains some drivers that i can't find neither on the esupport.sony.com nor on vaio-link.com. also can i use the drivers from the european site for the us model?

    many thanks!

  5. #285
    Newbie
    Join Date
    May 2010
    Posts
    1
    Rep Power
    0

    Default Re: Windows 7 on Vaio Z - Procedure

    Thank, thank, thank mailslat - for the more verbose version of the fix!

    I tried for hours to get the WWAN card on my Vaio VGN-Z31MN working with Windows 7 64-bit professional and a "3" SIM card. The one thing which I now realise I was missing was the Sony Firmware Extension Parser 8.0, which is not actually listed as an essential download in the Sony Windows 7 software download page for this machine. I would never have guessed that the WWAN + SIM card had anything to do with "a human interface device" and a "Sony Firmware Extension Parser Device".

    And it is true that the very last stage of the process, once the parser thing is there in Device Manager (open this by right clicking within Devices and Printers) you need a final reboot (after installing the WWAN drivers). This results in the system loading the driver for the WWAN card.

    A couple of additional tips though:-

    Tip No. 1
    There is a two stage process for installing the WWAN drivers. First by clicking on the Windows batch file (extension ".bat"), all the compressed files are extracted into two other folders. Then you need to go into those two folders and click on setup.exe in each one (or just setup if your settings are such that the extensions are not shown). These setup programs then install the drivers. Then as mentioned above, you must reboot to load them. However, I had a problem installing the WWAN drivers and I believe this has happened to other people as well. Some of the files would not extract because of a "path too long" problem. On my machine, this was because the folder names created by the installer for the WWAN drivers were so long that they went over the Windows limit (which I believe is 256 characters) when added to my own user name (which is actually quite short). The fix for this problem is as follows. When you click on the Windows batch file it tells you where the files are going to be extracted to, but it gives you an option to change the folder name. I would suggest changing it to WWAN_DRIVERS on your hard disk, or something like that which is much shorter than the suggested name.

    Tip No. 2
    The connection manager which is used on the VGN-Z machines is OneClick Internet. I could not get any help file for this working so how it works is a bit of a mystery. I think it is possible that I got the sequence of downloads in slightly the wrong order, because when I started OneClick Internet it started to look for the Verizon Network, and also insisted on a username and password which I don't think we use in the UK. I believe Verizon is a mobile phone company in the USA. But the VGN-Z machines are sold in the UK. So you need to change the settings on OneClick Internet to suit your sim card. To do this, click settings and tab to where you can change the carrier details (sorry after I did this the tab disappeared altogether and I can't remember what it was called, but I seem to recall it was the one on the extreme right hand side), and for "3" anyway you can choose Generic (UMTS). Changing this caused OneClick Internet to say that some firmware was being loaded into the connection manager (seemingly through my wired internet connection, not the sim), the 3 network was then found, and the APN setting was automatically loaded in the profile. For "3" this was "three.co.uk" without the quotation marks. It is possible that if you get the loading sequence correct in the first place then the correct firmware is loaded automatically.

  6. #286
    Notebook Enthusiast
    Join Date
    Sep 2008
    Posts
    35
    Rep Power
    15

    Default Re: Windows 7 on Vaio Z - Procedure

    So; I'm in Holland, I have a T-Mobile SIM. The Gobi 2000 is all set up, I have OneClick Internet running, with the correct firmware and it detects the SIM and the network.

    Problem is, when I hit connect, I get this; "Connection error. Error = 0".

    Not the most useful diagnostic ever.

    Anyone have any suggestions / experience with this? I've done a fair bit of Googling and got nothing; Sony have no clue what OneClick error codes mean.

    (When I try to connect through Windows, I get "APN is incorrect", which it *really* is not).

    (Finally, I note OneClick claims three bars of five, Windows claims one bar of five. I moved the laptop to a location where I had with Windows two bars from five; still the same errors for both software).

  7. #287
    a҉r҉t҉h
    Join Date
    Dec 2008
    Posts
    1,910
    Rep Power
    22

    Default Re: Windows 7 on Vaio Z - Procedure

    Quote Originally Posted by Blank Xavier View Post
    Finally, I note OneClick claims three bars of five, Windows claims one bar of five.
    "Number of bars" for indicating network connectivity doesn't have a universal system.
    To double the range, you need to quadruple the signal strength. So what's displayed as four bars on one system (that shows power) might be displayed as two bars on another (that shows range).

    To make it even worse, some just measure the dB attenuation of the signal, and dB is a logarithmic scale. Displaying that linearly leads to a display that will show full bars most of the time, and then drop off towards 0 or 1 very quickly once the signal reaches a certain point. In which case you might not notice any difference whatsoever between one bar and four bars.

    In short, don't worry about number of bars, and measure your network throughput instead (once you're connected, obviously).

  8. #288
    Notebook Enthusiast
    Join Date
    Sep 2008
    Posts
    35
    Rep Power
    15

    Default Re: Windows 7 on Vaio Z - Procedure

    So, it works now.

    There was nothing wrong with my Vaio-side setup.

    The provider hadn't done something - activation, something like that - and this morning, it all works.

    Last night, I took the SIM out and made a call from my phone - I had a suspicion the network needed to see the SIM *do* something, to then go activate it. Maybe that helped. Maybe it was totally unnecessary.

    I also note that, as ever, from the customer point of view, the service/configuration/behaviour of the provider is disjoined and broken. Large companies are inherently unable to provide correct information to customers.

    This is one of the reasons forums are so important. People figure out information - basic, essential, you-can't-make-the-service-work-without-this information - the provider is incapable of providing - or where the provider provides specifically incorrect information.

    For those of you using Ben in the Netherlands, here's what you need to do;

    1. follow the Gobi 2000 driver install instructions in this thread; unlike every other piece of hardware you've ever seen, installing the drivers is not what you need to do to make it work - it's just a red herring in this case - you need to install about six different pieces of software, almost none of which have any obvious connection to mobile broadband

    2. here I'm guessing a bit, but; I put the SIM in my laptop first, because I wondered if it would associate in some way with the first device it saw. Later, I put it in my phone to see if it needed to do other things; other things happened, but I don't know if they were necessary. Don't forgot to try making a call from the SIM from your phone - this may be necessary to get Ben to activate the account/SIM.

    3. You DO need the WebToGo OneClick Internet connection manager, because it offers Gobi 2000 specific functionality which you need to get the Gobi 2000 working. First, you need to select the correct Gobi 2000 image, and you can only do this from WebToGo. Go to Settings and to Firmware. You need to select the correct firmware for your provider. For me, if there is autodetection, it didn't work. I had to manually select the correct provider (T-Mobile in my case, Ben is a brand of theirs).

    4. Also in WebToGo, you will find a profile, which is used for the login attempt. This profile is set up with default values - you might guess they came from the SIM and so are correct, but you'd be wrong. For example, the login name is "webtogo". For Ben. the APN is "internet.ben", the username and password are empty - you leave them blank. Select "Use automatic DNS settings". You don't need to use a proxy. Note Ben do NOT tell you the APN name, either in the package you're sent or in email. If you *know* what it is, you can search for it on their site and find it, but you're never going to find that yourself manually! I found it via Google.

    5. You don't get told your phone numbe in the package Ben send you. I found mine out by sending an SMS from the Vaio - you can do this via WebToGo, by clicking on the SMS button, which brings up an app for sending/receiving SMS.

    7. You can send SMS even though you can't connect to the mobile broadband functionality, so you can find out your phone number this way.

    8. Even with your phone number (and it's the SIM number, not the contact number you gave to Ben when you joined), you can't log into your account on the ben.nl web-site. It tells you "I don't know your phone number". Ignore any information on the site about you having been sent when you joined Ben (which to me meant when I opened my account, because I had a few emails then) an email with your password in. You were not sent that password when you bought your SIM; you haven't yet been sent that email. For me, I was using the SIM yesterday from about 2pm onwards. That email arrived this morming at 5.42am. There's a big gap where you're very confused and wondering why the hell you can't log in.

    9. Having set everything up, when I clicked on Connect, I received the following; "Connection error. Error = 0". This seems to mean "the provider hadn't activated your SIM/account yet, you just need to wait".

    10. I suspect when the time comes you *can* log in on the Ben site, your account is ready and will let you connect to mobile broadband.

    11. Once everything is going, I think you can use the normal Windows wireless manager to connect to mobile broadband. I tried initially to manually set up an entry, but I couldn't find any way to do it. Then I noticed Windows had done this by itself. You need to configure that entry and set the APN name to the correct value.

    12. Final note; Sony don't know what the error codes from WebToGo are. One thing though. I told the guy I had my own install of Windows (which puzzled him - "why would you do that?"). He said Sony don't support custom installs. However, what they appear to really mean is *they can't promise to fix it for you*. I think this is, from their POV, the main issue - with their install, part of the deal is they *HAVE* to fix things. Obviously, with a custom install, it's impossible - you could utterly have screwed up your Vaio. But regardless of the custom install, they will answer the questions you send to them - so they *could* be helpful at getting the information you need to fix it. I didn't have to ask questions, in the end, since someone else - in this thread - figured out Sony's mess about what has to be done to get the Gobi working.

    All in all, Sony stink (appalling driver install for Gobi) and Ben stink (appalling customer experience - total lack of information and existence of misinformation). I have a degree in Computer Science, twenty years experience with Windows and I write Windows drivers and *I* couldn't see WTH was going on. I have *no* idea how someone who *isn't* an out-and-out computing professional *ever* gets this stuff to work.
    Last edited by Blank Xavier; 10th July 2010 at 05:31 AM.

  9. #289
    Notebook Enthusiast
    Join Date
    Sep 2008
    Posts
    35
    Rep Power
    15

    Default Re: Windows 7 on Vaio Z - Procedure

    So I'm connected over T-Mobile. HTTP works, SMTP/POP works, SSH works.

    Windows File/Folder Sharing isn't working. I also note Steam doesn't seem to be able to scan any servers. Bad feeling about this :-/ have other people got file/folder sharing working over mobile broadband?

  10. #290
    Notebook Virtuoso
    Join Date
    Sep 2006
    Posts
    2,223
    Rep Power
    28

    Default Re: Windows 7 on Vaio Z - Procedure

    Sorry if this is overly obvious or if it is just an EU-model problem with the Smart Network vs the US's SmartWi, but I've done a few* clean reinstalls and simply followed the directions Sony gave:

    Sony eSupport - VPCZ11FHX/XQ - Software Updates & Drivers

    Required: Sony® Shared Library
    This update is required if you have performed a clean install of the Windows 7 operating system (i.e., installed from a commercial, off-the-shelf, version rather than using the Recovery Wizard or Recovery Media).

    Required: VZAccess Manager Utility
    This update is required if you have performed a clean install of the Windows 7 operating system (i.e., installed from a commercial, off-the-shelf, version rather than using the Recovery Wizard or Recovery Media).

    Required: Qualcomm® Gobi™ 2000 Wireless HS-USB Modem 9225 Driver
    This update is required if you have performed a clean install of the Windows 7 operating system (i.e., installed from a commercial, off-the-shelf, version rather than using the Recovery Media).
    Required = Unless stated otherwise, this file must be installed BEFORE the SmartWi™ Connection Utility in order for it to work properly.

    If more than one Required file is listed, install them in the order presented on this page. Related (optional) files should not be considered in the installation order.
    I install the SmartWi last and I've had no problems. The newer version is much easier to work with than the WWAN option in the 1st gen Z's. Kind of unfortunate since I purchased an HTC EVO 4G and use it for broadband now.

    *A few means far too many times
    Sony Pro 11 (daily driver) | Sony Pro 13 | Sony Duo 13 | Sony Z2 | MacBook Air 11"

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 09:56 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1