Quantcast VAIO Service Utility?

Closed Thread
Page 1 of 4 1234 LastLast
Results 1 to 10 of 37
  1. #1
    Notebook Evangelist
    Join Date
    Jul 2007
    Posts
    532
    Rep Power
    20

    Default VAIO Service Utility?

    Anyone know what this does?

    After the SP1 upgrade, my mute button ceased to function. I installed Sony's BIOS update, but that didn't help. I traced the problem to VAIO-SUTOOL.exe, which is part of the VAIO Service Utility folder.

    The folder has an uninstaller, but without the ability to reinstall, I'm wondering if I need the software. No documentation exists explaining its purpose, and Sony technical support is as clueless as usual.

    VAIO-SUTOOL.exe wasn't in msconfig or services.msc, leading me to believe that it was called upon by another process. I also checked the Task Scheduler, but no luck there. For now I've simply renamed it to VAIO-SUTOOL_.exe, effectively eliminating its activation on startup and the problem it creates.

    But I'd rather treat the cause than the symptoms.

    Thoughts?

    Thanks,
    Peter
    Last edited by NinjaNoodles; 11th April 2008 at 03:08 PM.
    Premium Web and Graphic Design

    Black flash after Windows loads?
    REMOVE BLOATWARE: Optimize Any Sony VAIO With a Semi-Clean Install!
    CONFIRMED: CR, SZ, FZ, AR, TZ, FE, NR | AWAITING RESULTS: NEWER MODELS | FAILED: NONE

  2. #2
    Notebook Evangelist
    Join Date
    Jul 2007
    Posts
    532
    Rep Power
    20

    Default Re: VAIO Service Utility?

    Some information about what it does, but not what it's for: http://www.prevx.com/filenames/20239...UTOOL.EXE.html
    Premium Web and Graphic Design

    Black flash after Windows loads?
    REMOVE BLOATWARE: Optimize Any Sony VAIO With a Semi-Clean Install!
    CONFIRMED: CR, SZ, FZ, AR, TZ, FE, NR | AWAITING RESULTS: NEWER MODELS | FAILED: NONE

  3. #3
    Notebook Evangelist
    Join Date
    Jul 2007
    Posts
    532
    Rep Power
    20

    Default Re: VAIO Service Utility?

    Nobody knows?
    Premium Web and Graphic Design

    Black flash after Windows loads?
    REMOVE BLOATWARE: Optimize Any Sony VAIO With a Semi-Clean Install!
    CONFIRMED: CR, SZ, FZ, AR, TZ, FE, NR | AWAITING RESULTS: NEWER MODELS | FAILED: NONE

  4. #4
    NBR Vaio Team Curmudgeon
    Join Date
    Jun 2007
    Posts
    6,044
    Rep Power
    44

    Default Re: VAIO Service Utility?

    Dosn't exist on my FZ, so I am at a loss.
    Gary

  5. #5
    Notebook Evangelist
    Join Date
    Jul 2007
    Posts
    532
    Rep Power
    20

    Default Re: VAIO Service Utility?

    Gary, no C:\Program Files\Sony\VAIO Service Utility folder?
    Premium Web and Graphic Design

    Black flash after Windows loads?
    REMOVE BLOATWARE: Optimize Any Sony VAIO With a Semi-Clean Install!
    CONFIRMED: CR, SZ, FZ, AR, TZ, FE, NR | AWAITING RESULTS: NEWER MODELS | FAILED: NONE

  6. #6
    NBR Vaio Team Curmudgeon
    Join Date
    Jun 2007
    Posts
    6,044
    Rep Power
    44

    Default Re: VAIO Service Utility?

    Nope. Only the onesd show in the attachment.

    Gary
    Attached Thumbnails Attached Thumbnails Capture.JPG  

  7. #7
    Notebook Evangelist
    Join Date
    Jul 2007
    Posts
    532
    Rep Power
    20

    Default Re: VAIO Service Utility?

    You think it was there before your clean install? It's not in the recovery center, but it came on my computer.
    Premium Web and Graphic Design

    Black flash after Windows loads?
    REMOVE BLOATWARE: Optimize Any Sony VAIO With a Semi-Clean Install!
    CONFIRMED: CR, SZ, FZ, AR, TZ, FE, NR | AWAITING RESULTS: NEWER MODELS | FAILED: NONE

  8. #8
    NBR Vaio Team Curmudgeon
    Join Date
    Jun 2007
    Posts
    6,044
    Rep Power
    44

    Default Re: VAIO Service Utility?

    I don't think so. I did a complete inventory before the clean install.

    There is no mute button on the FZ, what model do you have again, I forgot.

    Gary

  9. #9
    Notebook Evangelist
    Join Date
    Jul 2007
    Posts
    532
    Rep Power
    20

    Default Re: VAIO Service Utility?

    I have a CR190.

    The fact that the mute button is affected by this leads me to believe that the VAIO Event Service is calling the VAIO Service Utility to work, and the two are doing something hand in hand.

    Just a guess, though.

    I guess, for now, I'll just leave it renamed instead of uninstalled.

    -Peter
    Premium Web and Graphic Design

    Black flash after Windows loads?
    REMOVE BLOATWARE: Optimize Any Sony VAIO With a Semi-Clean Install!
    CONFIRMED: CR, SZ, FZ, AR, TZ, FE, NR | AWAITING RESULTS: NEWER MODELS | FAILED: NONE

  10. #10
    Newbie
    Join Date
    Mar 2008
    Posts
    5
    Rep Power
    16

    Default Re: VAIO Service Utility?

    My mute button also stopped working i think after SP1. You just renamed this .exe and your mute button now works?

 

 
Page 1 of 4 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 08:33 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1