Quantcast Atheros AR9285 and "n" mode

Closed Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Notebook Enthusiast
    Join Date
    Jan 2010
    Posts
    14
    Rep Power
    11

    Default Atheros AR9285 and "n" mode

    I purchased the Asus Eee PC MK90H on Amazon for my daughter, which lists the following under specs: WLAN: 802.11b/g/n (draft 2.4GHz n). However, when I try to use the netbook with my D-Link DIR-655 in "n" only mode (at 2.4GHz), I cannot get the netbook to connect to the Internet. When I switch the router to mixed g/n mode, it connects.

    I went into the Device Manager of the MK90H and notice that the wireless card is Atheros AR9285, and, under Properties, the following shows under Wireless mode selection -- Auto or 802.11 b/g.

    Does this mean the wireless card does not support .11n?

    Thanks.

  2. #2
    NBR Super Moderator
    Join Date
    Oct 2005
    Location
    Secret Laboratory
    Posts
    7,130
    Rep Power
    55

    Default Re: Atheros AR9285 and "n" mode

    No it means that it's either auto (b/g or n) or forced b/g if you specifically do not want 802.11n. Leave it at auto.
    You do know that you need security set to WPA2 and AES for 802.11n to work, right?

  3. #3
    Notebook Enthusiast
    Join Date
    Jan 2010
    Posts
    14
    Rep Power
    11

    Default Re: Atheros AR9285 and "n" mode

    Thanks. It's on Auto. And, yes, WPA2 and AES are both selected. I've been using an "n" only environment for months, and I have had no wi-fi connection problems with any of my devices (including ... knock on wood ... the iPad). But while the MK90H "connects" to the router when it is in "n" mode, there is no Internet access. I am able to access the Internet only when I switch it to a mixed g/n environment.

  4. #4
    NBR Super Moderator
    Join Date
    Oct 2005
    Location
    Secret Laboratory
    Posts
    7,130
    Rep Power
    55

    Default Re: Atheros AR9285 and "n" mode

    Damn I hate this particular card- it always means trouble
    Are your wireless channels are set to 20MHz?
    Did you try updating the drivers?
    At what speed does the notebook connect when in "n" mode?
    What's missing that it doesn't have internet access- DNS, gateway?
    I assume the OS is up to date.

  5. #5
    Notebook Enthusiast
    Join Date
    Jan 2010
    Posts
    14
    Rep Power
    11

    Default Re: Atheros AR9285 and "n" mode

    I don't have the machine or router in front of me, but I believe the wireless channel is set to 20/40 (auto) on the router. Could be wrong.
    I looked last night for drivers for this card but couldn't find any. The one listed on the Asus site is the one installed.
    On speed and on what's missing, I will need to answer those questions tonight when I have access to the netbook.
    Yes, the OS on the netbook is XP and all updates have been installed.
    As an aside, how difficult is it to replace the wireless card in a netbook? In my laptop, it was easy, but not sure about the netbook. Maybe I can get a solid wireless card for the netbook.

  6. #6
    NBR Super Moderator
    Join Date
    Oct 2005
    Location
    Secret Laboratory
    Posts
    7,130
    Rep Power
    55

    Default Re: Atheros AR9285 and "n" mode

    It should be pretty easy to upgrade to something decent like Intel 5300 but for now here is slightly newer driver than the one Asus lists on their support page.
    Why am I sure it won't help?

  7. #7
    Notebook Enthusiast
    Join Date
    Jan 2010
    Posts
    14
    Rep Power
    11

    Default Re: Atheros AR9285 and "n" mode

    Thanks. I'll give it a try, but won't hold my breath.

  8. #8
    Newbie
    Join Date
    Oct 2010
    Posts
    1
    Rep Power
    0

    Default Re: Atheros AR9285 and "n" mode

    trclac, I had the same issue with a Sony Vaio laptop (i5, Windows 7, Linksys WRT310, Atheros AR9285).

    To make a long story short....I used WPA2-Personal with AES, and entered the encryption key in CAPS, and finally it worked! Please try and see if you have success as well.

    To make a short story long....Everytime I attempted to configure my Linksys WRT310 for "N only", I could only gain access with my VAIO by going "WPA-Personal" with no security.

    Because of this security issue, I added MAC filtering on the router (shouldn't make a difference for your issue) and enabled "adhoc 11n in device manager for my Atheros adapter. After reading your post, I went with WPA2-Personal and AES security encryption, again to no avail. I attempted the same with a wireless-N adapter on my wife's laptop, but it worked.

    Only after entering the encryption password in caps did I have success. Must be an issue with Atheros.

    Incidentally, I had called Sony support about this the day before, with no solution - to be honest though, the Sony guys are usually pretty good).

  9. #9
    Lord Pringles
    Join Date
    Feb 2009
    Location
    Malaysia
    Posts
    3,229
    Rep Power
    27

    Default Re: Atheros AR9285 and "n" mode

    I don't have problem with my AR9285 wireless card & "n" mode.

    These are what I have right now to test it:-
    - Asus A42JV notebook with Atheros AR9285 wireless card
    - LevelOne WBR-6002 2.4GHz 150mbps 802.11n compliant wireless AP.
    --> Currently set to "N Only".
    --> Security setting WPA2-PSK with AES encryption.
    --> Bandwidth set to Auto (20MHz + 40MHz)

    Result:-
    - AR9285 can connect to AP on "N" mode & with 150Mbps.

    I have another AP; LevelOne WBR-6001 300Mbps 802.11n compliant wireless AP which I can test later.

    Conclusion:-
    - My AR9285 probably newest revision. The problematic AR9285 probably an older revision.

    On slightly related note; Intel WiFi Link 5300 AGN on my Dell Studio seems unstable. The connection speed always change between 58MHz, 65MHz & 72MHz when connected to same AP, regardless 802.11 mode (b+g+n or N only).

    Please let me know if my test incomplete or I missed something.
    Dell Studio 1557 | Intel Core i7-720QM - CPU Microcode Update Rev 4 | 4GB | dGPU: ATI Mobility Radeon HD 4570 + eGPU: PowerColor HD 5870
    Asus A42JV/K42JV | Intel Core i5-450M | 4GB DDR3 1066MHz | nVidia GeForce GT 335M 1GB DDR3 with Optimus technology | WLED 1366x768 14"
    Phoenix BIOS MOD Request | Acer Notebook Clock Generators/PLL | Guide to BIOS mod for Dual-IDA

  10. #10
    Notebook Consultant
    Join Date
    Mar 2010
    Posts
    203
    Rep Power
    11

    Default Re: Atheros AR9285 and "n" mode

    the atheros brochure states its a 150mbps N card

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 09:40 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1