Quantcast Problems with turbo memory - ianvstor.sys

Closed Thread
Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1
    Notebook Enthusiast
    Join Date
    Sep 2007
    Posts
    27
    Rep Power
    17

    Default Problems with turbo memory - ianvstor.sys

    Until last night, my T61 was pretty stable, even with Turbo Memory activated. I had previously changed the power saving options that caused hangs while using the notebook on battery power. I have the latest TM driver from Lenovo.

    Last night my computer suddenly blue screened. I didn't get a chance to read the screen before it attempted to reboot. However, as Vista was loading, it blue screened again. It was complaining about 'ianvstor.sys.' This continued as I tried booting into safe mode and selecting various options with rescue and recovery. I could not get my T61 to boot at all before it crashed again.

    Finally, I booted Knoppix from DVD and mounted the Windows partition. I renamed 'ianvstor.sys' in the \windows\system32\drivers directory, and rebooted. This time Vista booted without incident. Vista automatically disabled Readyboost and Readydrive because it could not locate ianvstor.sys. (because I renamed it).

    I have left it disabled for now. Hopefully, this will help someone else who may encounter this problem where the system cannot boot.

    Has anyone else had this problem? and have you found a fix?
    Last edited by dayphx; 7th January 2008 at 11:19 AM.

  2. #2
    Notebook Geek
    Join Date
    Aug 2007
    Posts
    99
    Rep Power
    18

    Default Re: Problems with turbo memory - ianvstor.sys

    Intel has an even newer Turbo Memory driver than Lenovo offers. Maybe try installing that.

  3. #3
    Notebook Evangelist
    Join Date
    Nov 2007
    Posts
    311
    Rep Power
    18

    Default Re: Problems with turbo memory - ianvstor.sys

    No problems yet, but I am beginning to think that Turbo is like a timebomb ticking away inside my TP...
    Desktop paperweight:
    T61P, T7800 2.6G C2D, 4GB, 15.4 WUXGA TFT Samsung, Quadro FX570M 256M, 160G 7200 Hitachi 7K200 HD, 1G Turbo Mem, Intel Wifi 4965 AGN, Vista32 Biz

    Mobility solution:
    X200 Tablet, SL9400, 4GB, Multiview/ Multitouch Samsung WXGA LED w/ Cam, 160G 7200 Hitachi 7K320 HD, Intel Wifi 5300 AGN, Vista64 Biz

  4. #4
    Notebook Enthusiast
    Join Date
    Sep 2007
    Posts
    27
    Rep Power
    17

    Default Re: Problems with turbo memory - ianvstor.sys

    I am beginning to think it's not worth the risk to use Turbo Memory until it matures more. I was worried I would not be able to recover without reloading Vista. I haven't tried Intel's driver since my system has been stable for a few months.

    I think there's a reason Lenovo doesn't have the latest and greatest drivers. I allowed Windows update to load new drivers for my nvida card. Occationally, the video driver would cause a blue screen. I have since reloaded the version from Lenovo, and haven't had any problems with it.

  5. #5
    Notebook Consultant
    Join Date
    Jun 2007
    Posts
    129
    Rep Power
    18

    Default Re: Problems with turbo memory - ianvstor.sys

    Get the latest drivers from Intel, initially I've had these problems as well but now it's fixed. I have not had a blue screen in nearly 6 months.

  6. #6
    Notebook Deity
    Join Date
    Aug 2007
    Location
    IL
    Posts
    1,795
    Rep Power
    25

    Default Re: Problems with turbo memory - ianvstor.sys

    disable the hybrid disc power saving option in power management
    ThinkPad T61|14in WS Samsung WXGA w/ cam|T7300|3gb RAM|160gb 5400rpm HD|X3100|Fingerprint Reader|Turbo Memory|BT|7cell Batt|Vista x86 Ultimate|NMB KB|

  7. #7
    Newbie
    Join Date
    Jan 2008
    Location
    Kent, England
    Posts
    6
    Rep Power
    17

    Default Re: Problems with turbo memory - ianvstor.sys

    Hi dayphx, I've just experienced exactly the same thing: blue screens etc. and it won't boot even in safe mode.

    Anyone got any advice on what I can do - is there a fix? The last thing I want to do is format!

    Help
    Lenovo T61p; T7500 2.2GHz Core 2 Duo; 4GB PC2-5300; 15.4 WSXGA+; Quadro FX 570M 256; 100GB 7200prm; 1GB Turbo Mem; Bluetooth; Vista Biz 64

  8. #8
    Notebook Evangelist
    Join Date
    Dec 2007
    Posts
    361
    Rep Power
    18

    Default Re: Problems with turbo memory - ianvstor.sys

    Does the hybrid disc power saving cause this error?

  9. #9
    Newbie
    Join Date
    Jan 2008
    Location
    Kent, England
    Posts
    6
    Rep Power
    17

    Default Re: Problems with turbo memory - ianvstor.sys

    Quote Originally Posted by arlab View Post
    Does the hybrid disc power saving cause this error?
    I haven't the faintest idea, I just launched an application and got the blue screen, it went downhill from there...

    It's definitely referring to a problem with iaNvstor.sys
    Lenovo T61p; T7500 2.2GHz Core 2 Duo; 4GB PC2-5300; 15.4 WSXGA+; Quadro FX 570M 256; 100GB 7200prm; 1GB Turbo Mem; Bluetooth; Vista Biz 64

  10. #10
    Newbie
    Join Date
    Jan 2008
    Location
    Kent, England
    Posts
    6
    Rep Power
    17

    Default Re: Problems with turbo memory - ianvstor.sys

    I've downloaded Knoppix and have booted from CD, located the iaNvstor.sys file in Windows\System32\Drivers directory but when I try to rename it I get an Error saying it cannot be deleted. Could anyone tell me what I'm doing wrong please?

    Thanks
    Lenovo T61p; T7500 2.2GHz Core 2 Duo; 4GB PC2-5300; 15.4 WSXGA+; Quadro FX 570M 256; 100GB 7200prm; 1GB Turbo Mem; Bluetooth; Vista Biz 64

 

 
Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 12:12 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1