Quantcast Samsung R519, power on but nothing came

Closed Thread
Results 1 to 4 of 4
  1. #1
    Notebook Enthusiast
    Join Date
    Jun 2011
    Posts
    10
    Rep Power
    9

    Default Samsung R519, power on but nothing came

    I was working on my laptop yesterday when suddenly the screen went blank. The laptop wasn't responding, so I held down the power button to force it to switch off. Now the laptop won't boot up. The battery charge light is on and when I switch it on the power light comes on. The other light just briefly flashes on. I can see the fan runs a few seconds and stopped and never runs again. Any ideas? The laptop is only 12 months old!

    Any ideas would be greateful.

    Thank you

  2. #2
    Wisdom listens quietly...
    Join Date
    Aug 2009
    Posts
    9,006
    Rep Power
    52

    Default Re: Samsung R519, power on but nothing came

    Try unplugging the machine from the wall - remove the battery and press each and every key/button switch on it a few times (each).

    You can also try to re-seat the RAM modules and also the HDD, optical drive and any other cards (wan/bluetooth, etc.) that you can get to.

    Leave the system with no power or battery installed for a few hours.

    When you put in the battery again, plug in the power and see if it charges the battery.

    Assuming that the charging part of the system works - let it continue charging until you have an indication that it is fully charged and then see if it boots up for you.

    Good luck.

  3. #3
    Notebook Enthusiast
    Join Date
    Jun 2011
    Posts
    10
    Rep Power
    9

    Default Re: Samsung R519, power on but nothing came

    Dear tilleroftheearth

    thanks for your info. I have followed your steps. I have power on first time, then it comes on the screen but after some times, it frozen and couldnt go ahead. then I have switched off using the power button. and I tried next time but same nothing comes on screen. the fan not running at all.

    Is any other ideas to solve this ?

    thank you

  4. #4
    Wisdom listens quietly...
    Join Date
    Aug 2009
    Posts
    9,006
    Rep Power
    52

    Default Re: Samsung R519, power on but nothing came

    When you tried it the 'next time'... did you remove power/battery and let it sit there again for a few hours?

    I am guessing that either your power adaptor brick or your motherboard is damaged somehow.

    Try to boot the system with only a single stick of RAM installed (try both slots too, with each stick...). Try to boot with a USB or CD/DVD Ubuntu Live CD (to check for O/S corruption...). Try just going into the BIOS and seeing if the system can idle there stable - if it can, does it show temperatures and/or fan speeds? Maybe a fan or two has kicked the bucket.

    Try to get/test/borrow an identical power adaptor to see if that solves your issue. If all of the above fail to give any relief, I would be looking for a new system (and not looking to 'revive' this system with the chance for it to fail again).

    Good luck.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 09:52 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1