Quantcast XPS M1330 won't turn on: motherboard or GPU failure?

Closed Thread
Page 1 of 4 1234 LastLast
Results 1 to 10 of 35
  1. #1
    Notebook Enthusiast
    Join Date
    Nov 2007
    Posts
    14
    Rep Power
    18

    Default XPS M1330 won't turn on: motherboard or GPU failure?

    Hi everyone,

    I was web surfing with my XPS m1330 last night (purchased 11/30/07) and it gave a small chirp and turned off immediately (did not go through the normal shutdown process). I tried to turn it on again in the hopes that it had overheated (though it was on a hard flat surface and I had literally just started using it - I had woken it up from "sleep" less than a minute earlier), but it wouldn't turn on. I decided to leave it overnight - still won't power on this morning. I've tried two different adapters on different outlets, the one that comes with the system and the Dell travel adapter that you can buy as an accessory - neither works (I think the adapters are fine though, since the LED lights on them come on when you plug them in, although the lights immediately turn off once you plug the adapter into the computer). I've tried using the adapters with the battery inserted (fully charged, according to the LCD lights on it) and with it not inserted - no power.

    Does this sound like a motherboard failure or a GPU failure or something else to you? The machine won't power up at all, so I'm thinking the former or something to do with the internal power supply perhaps, but I'd love to get your opinions on this. Thanks.

  2. #2
    Moderately Boss
    Join Date
    Aug 2007
    Location
    Sydney
    Posts
    11,160
    Rep Power
    68

    Default Re: XPS M1330 won't turn on: motherboard or GPU failure?

    Try taking the battery pack out and AC power

    Hold the power button for 30 seconds

    This time try powering on with only AC power
    . #flickr
    [Desktop] Silverstone LC20B | Q8200 2.8ghz | GTX680OCE | 8GB RAM | 128GB M4 SSD | 12TB HDD | Intel 6300N | Dell U3014
    [Notebook] HP DV2500 Verve SE | T7500 | 8400GS | 4GB DDR2 RAM | WD 250GB HDD | Intel 4965AGN |
    [Worktop] NZXT Apollo | i7-3770 | GTX 460SE | 12GB DDR3 | 120GB Intel 330 SSD | M-Audio Delta 66 | Dell U2913

  3. #3
    Notebook Enthusiast
    Join Date
    Nov 2007
    Posts
    14
    Rep Power
    18

    Default Re: XPS M1330 won't turn on: motherboard or GPU failure?

    Hi Flipfire:

    I've plugged the adapter that comes with the XPS into the wall (blue LED comes on), then I've plugged the adapter into the XPS power port (blue LED goes off immediately) and held the power button down for 30 seconds (XPS battery removed) - machine does not power up. I've repeated the procedure with the travel adapter (green LED comes on and then goes off immediately once I plug it into the XPS) - machine does not power up.

  4. #4
    Moderately Boss
    Join Date
    Aug 2007
    Location
    Sydney
    Posts
    11,160
    Rep Power
    68

    Default Re: XPS M1330 won't turn on: motherboard or GPU failure?

    Your gonna have to call and get it replaced im afraid.

    Power rail is dead
    . #flickr
    [Desktop] Silverstone LC20B | Q8200 2.8ghz | GTX680OCE | 8GB RAM | 128GB M4 SSD | 12TB HDD | Intel 6300N | Dell U3014
    [Notebook] HP DV2500 Verve SE | T7500 | 8400GS | 4GB DDR2 RAM | WD 250GB HDD | Intel 4965AGN |
    [Worktop] NZXT Apollo | i7-3770 | GTX 460SE | 12GB DDR3 | 120GB Intel 330 SSD | M-Audio Delta 66 | Dell U2913

  5. #5
    Notebook Enthusiast
    Join Date
    Nov 2007
    Posts
    14
    Rep Power
    18

    Default Re: XPS M1330 won't turn on: motherboard or GPU failure?

    Gah, sadness - I'm traveling to Germany next week and I was hoping to use it there. Thanks for helping to diagnose my problem though. Do you think they'll send me a refurbed system or the same machine? I've not used it much, so it's still relatively "shiny". Also, I upgraded the RAM to 4GB - should I remove it and go back to the original stick of RAM or will I be ok with leaving it in there?

  6. #6
    walk in see this wat do?
    Join Date
    Dec 2007
    Location
    Honduras, Central America.
    Posts
    1,128
    Rep Power
    22

    Default Re: XPS M1330 won't turn on: motherboard or GPU failure?

    You have to get it replaced, Mom's m1330 just happened to had that problem...

    So yes, you need to send it in.

    XPS M1530 ~ mobo = dead
    SXPS 1640 ~ S O L D !
    GX660 vs GX600r?

    --------------------------
    Responsible for
    draining the laptop
    fund i had ~ 2007 Mustang GT/CS Vert

  7. #7
    Notebook Enthusiast
    Join Date
    Nov 2007
    Posts
    14
    Rep Power
    18

    Default Re: XPS M1330 won't turn on: motherboard or GPU failure?

    Hi BenLeonheart,

    Do you think the power rail died because I left the machine on sleep (plugged into the adapter, with the battery inserted) most of the time? I'm just wondering if it died prematurely because that might stress the rail too much?

  8. #8
    Moderately Boss
    Join Date
    Aug 2007
    Location
    Sydney
    Posts
    11,160
    Rep Power
    68

    Default Re: XPS M1330 won't turn on: motherboard or GPU failure?

    You will need to put the original parts back in or else Dell wont touch it.

    No, something most likely shorted or overloaded.
    . #flickr
    [Desktop] Silverstone LC20B | Q8200 2.8ghz | GTX680OCE | 8GB RAM | 128GB M4 SSD | 12TB HDD | Intel 6300N | Dell U3014
    [Notebook] HP DV2500 Verve SE | T7500 | 8400GS | 4GB DDR2 RAM | WD 250GB HDD | Intel 4965AGN |
    [Worktop] NZXT Apollo | i7-3770 | GTX 460SE | 12GB DDR3 | 120GB Intel 330 SSD | M-Audio Delta 66 | Dell U2913

  9. #9
    Notebook Enthusiast
    Join Date
    Nov 2007
    Posts
    14
    Rep Power
    18

    Default Re: XPS M1330 won't turn on: motherboard or GPU failure?

    Ok, thanks for the confirmation Flipfire. Appreciate the help again.

  10. #10
    Notebook Enthusiast
    Join Date
    Nov 2007
    Posts
    14
    Rep Power
    18

    Default Re: XPS M1330 won't turn on: motherboard or GPU failure?

    Wow, Dell is sending a tech out - I might be able to take my laptop with me to Germany next week! I'm so glad I bought from them and got the warranty. Thanks again for all the help, guys!

 

 
Page 1 of 4 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 10:59 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1