Quantcast D630 won't start up

Closed Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Notebook Enthusiast
    Join Date
    Jan 2008
    Posts
    37
    Rep Power
    16

    Default D630 won't start up

    Guy's

    came down this morning to find my D630 won't start,

    |No power light or anyother lights and the screen stays blank and no HDD noise can be heard. I held the on/off button down for 20 sec's to force a restart but stiil no joy

    swapped the battery for a known good one -same thing

    I've searched the Dell support but nothing as yet

    MB gone perhaps :-(

    Cheers

    Richard

  2. #2
    Moderately inquisitive
    Join Date
    Apr 2005
    Location
    Swindon, UK
    Posts
    24,564
    Rep Power
    126

    Default Re: D630 won't start up

    Try taking out and replacing the RAM. Sometimes the contacts oxidize which removal / replacement will fix and, if the BIOS can read the RAM properly then nothing starts.

    John

  3. #3
    Notebook Enthusiast
    Join Date
    Jan 2008
    Posts
    37
    Rep Power
    16

    Default Re: D630 won't start up

    many thanks for the reply but as nothing happens at all I would have thought the start process would begin then shut down on 'no ram' rather than as mine is -bricked :-(

  4. #4
    Moderately inquisitive
    Join Date
    Apr 2005
    Location
    Swindon, UK
    Posts
    24,564
    Rep Power
    126

    Default Re: D630 won't start up

    I'm aware that a RAM problem normally causes a few flashing lights. However, computers don't normally terminally die overnight unless subjected to external influences (eg power surge, dropped). Dismantle and reassembly may clear a poor contact somewhere and get it working.

    John

  5. #5
    Custom User Title
    Join Date
    Nov 2008
    Posts
    1,080
    Rep Power
    18

    Default Re: D630 won't start up

    Quote Originally Posted by r.bartlett View Post
    Guy's

    came down this morning to find my D630 won't start,

    |No power light or anyother lights and the screen stays blank and no HDD noise can be heard. I held the on/off button down for 20 sec's to force a restart but stiil no joy

    swapped the battery for a known good one -same thing

    I've searched the Dell support but nothing as yet

    MB gone perhaps :-(

    Cheers

    Richard
    Sounds not good. How about pulling the battery and trying with charger power only. Also remove any other connections and devices that you can (such as ODD) in the event a bad item is pulling everything down.

    GK

    06/10 Dell Latitude E6410 Core i7-620M nVidia Quadro NVS 3100M w/Express Card Win7 x64 reimage
    12/08 Dell Latitude E6400 Core 2 Duo P9500 nVidia Quadro NVS 160M w/Express Card Win7 x64 reimage WinVista x64 reimage
    This forum looks better and displays faster in vBulletin Default Style!

  6. #6
    Notebook Enthusiast
    Join Date
    Jan 2008
    Posts
    37
    Rep Power
    16

    Default Re: D630 won't start up

    Tried everything but still dead .

    Phoned Dell support for assistance and questioned the warranty as some MB's were known to overheat and fail due to the graphics.

    He said no warranty (as the Dell website states) but I questioned that and he came back with the fact that the warranty runs out in October this year so an engineer will be coming round my house tomorrow to fix FOC!

    I know Dell get a lot of stick but I can't fault them :-)

    Cheers

    Richard

  7. #7
    Notebook Deity
    Join Date
    Jun 2008
    Location
    Washington, USA
    Posts
    1,720
    Rep Power
    21

    Default Re: D630 won't start up

    The warranty on the motherboard has been extended for an additional year for D620 and D630 with Nvidia graphics. It doesn't show officially, but once the rep is aware of this, they will send out a motherboard without issue.
    DCSE, DDET, MCSA, MCTS, and MCITP Certified

    Dell Latitude E6410, Intel Core i5-560M 2.66GHz, 8GB RAM, NVIDIA NVS 3100M 512MB, 256GB Samsung PM810 SSD, Windows 7 Ultimate x64, Dell UltraSharp 2209WA

    Dell Latitude E6220, Intel Core i5-2520M 2.50GHz, 8GB RAM, 256GB Samsung PM830 SSD, Windows 7 Enterprise x64

    Dell OptiPlex 980 SMT, Intel Core i5-680 3.6GHz, 8GB RAM, 160GB Intel 320 Series SSD, 1TB Seagate Barracuda ES.2 HDD, Windows 7 Enterprise x64, Dell UltraSharp 2209WA

  8. #8
    Notebook Enthusiast
    Join Date
    Jan 2008
    Posts
    37
    Rep Power
    16

    Default Re: D630 won't start up

    Quote Originally Posted by Robin24k View Post
    The warranty on the motherboard has been extended for an additional year for D620 and D630 with Nvidia graphics. It doesn't show officially, but once the rep is aware of this, they will send out a motherboard without issue.
    That's why I questioned the warranty. However the record shows the start date as 4 October 2007 and as it's a 3 yr warranty the end date should have been Oct 10. However it stated "No warranty with this unit" Which is why he went away and looked into it. Then came back and said their engineer will be out tomorrow (today) to fix it as it is a 3 yr onsite warranty not RTB :-)

    as an update. I tried it this morning just to see and it started up. However it was going a bit mad and half the keyboard doesn't work. It restarts itself again and again then some fully beeps come up :-)

    Thanks to all


    Richard

  9. #9
    Newbie
    Join Date
    Jan 2011
    Posts
    6
    Rep Power
    8

    Default D630 won't start up

    Howdy,

    Old thread. did you fix it?


    I had a similar problem with my XFR D630.

    It all of a sudden would not power up at all......... pressing the power button would only cause the power "light" to flash briefly and go out.

    Strangely, it now powers up after being off for a few days. battery state or power supply connection didn't seem to make any difference.

    I have no warranty either. so the fix is all on me. I can buy a new mobo from ebay I suppose, but I'd like to know if someone else has had this problem.


    If it had not started working, my plan was (and still is) to take it apart and re-seat ALL the connections including the CPU to see if a poor connection was causing this.



    OS: Linux 2.6.34.7-0.7-default x86_64
    System: openSUSE 11.3 (x86_64)
    KDE: 4.4.4 (KDE 4.4.4) "release 3"

    Vendor: Intel Corporation
    Model: 965 GM
    2D driver: intel



    Anyone else with a problem like this?



    Cheers,


    Rick

  10. #10
    Notebook Deity
    Join Date
    Jun 2008
    Location
    Washington, USA
    Posts
    1,720
    Rep Power
    21

    Default Re: D630 won't start up

    It is possible there is a connection problem with the CPU. It wouldn't hurt to disassemble the system and visually inspect for problems. You can find the disassembly instructions here:

    http://support.dell.com/support/edoc...ata6400xfr/en/
    DCSE, DDET, MCSA, MCTS, and MCITP Certified

    Dell Latitude E6410, Intel Core i5-560M 2.66GHz, 8GB RAM, NVIDIA NVS 3100M 512MB, 256GB Samsung PM810 SSD, Windows 7 Ultimate x64, Dell UltraSharp 2209WA

    Dell Latitude E6220, Intel Core i5-2520M 2.50GHz, 8GB RAM, 256GB Samsung PM830 SSD, Windows 7 Enterprise x64

    Dell OptiPlex 980 SMT, Intel Core i5-680 3.6GHz, 8GB RAM, 160GB Intel 320 Series SSD, 1TB Seagate Barracuda ES.2 HDD, Windows 7 Enterprise x64, Dell UltraSharp 2209WA

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 02:09 AM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1