Quantcast Did i just broke my laptop when installing RAM wrong? - Page 2

Closed Thread
Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 37
  1. #11
    Notebook Consultant
    Join Date
    Sep 2009
    Location
    South Carolina, USA
    Posts
    109
    Rep Power
    13

    Default Re: Did i just broke my laptop when installing RAM wrong?

    I'm glad I haven't messed up my laptop, but everytime I open my laptop to do something, like I changed the cooling fan, installed ram, wireless card, antennas. I'm always scared that my laptop will not turn on after I put pieces back together

  2. #12
    Notebook Geek
    Join Date
    Jun 2008
    Posts
    84
    Rep Power
    16

    Default Re: Did i just broke my laptop when installing RAM wrong?

    okay i tried it and it still does not work

  3. #13
    Notebook Evangelist
    Join Date
    May 2008
    Posts
    409
    Rep Power
    17

    Default Re: Did i just broke my laptop when installing RAM wrong?

    Quote Originally Posted by dynamic140 View Post
    You want me to open the computer without any memory? I am not sure if there is memory on board.
    I was trying to find the old reference I thought by memory there was

    http://support.dell.com/support/edoc...n/sm/index.htm

    Just leave one module in the one you did not change

    unless you forced both

  4. #14
    Notebook Evangelist
    Join Date
    May 2008
    Posts
    409
    Rep Power
    17

    Default Re: Did i just broke my laptop when installing RAM wrong?

    Quote Originally Posted by dynamic140 View Post
    okay i tried it and it still does not work
    Just blank period no boot screen at all? If you change the memory you have to go into the set up sometimes, I would try to get into set up

  5. #15
    Notebook Geek
    Join Date
    Jun 2008
    Posts
    84
    Rep Power
    16

    Default Re: Did i just broke my laptop when installing RAM wrong?

    It took me a while to take out the 2 old ram. When i figured how to take out the first one, it took lot of forcing to take out second one. Then it took A TON of forcing to put in the 1st new one b/c i didnt know how but the 2nd one was easy because i then saw the hole.

    When i open my laptop, it has a sound that usually boots the computer. However, screen is black like when it is closed. In 7-8 seconds within starting the computer, it shuts off with the shutdown sound.

  6. #16
    Notebook Evangelist
    Join Date
    May 2008
    Posts
    409
    Rep Power
    17

    Default Re: Did i just broke my laptop when installing RAM wrong?

    Quote Originally Posted by dynamic140 View Post
    It took me a while to take out the 2 old ram. When i figured how to take out the first one, it took lot of forcing to take out second one. Then it took A TON of forcing to put in the 1st new one b/c i didnt know how but the 2nd one was easy because i then saw the hole.

    When i open my laptop, it has a sound that usually boots the computer. However, screen is black like when it is closed. In 7-8 seconds within starting the computer, it shuts off with the shutdown sound.
    WOW I'm so sorry, the way you make it sound.....

    I just feel like you broke the channel, get the magnifying glass out, serousily and exam the channel (slot) well and see if the pins are ok and if you broke any of the plastic.

    Do you know anyone that works on laptops? I think you need help. If you were around me I would look at it for you (For free of course lol)

  7. #17
    NBR Super Moderator
    Join Date
    Jul 2006
    Location
    NBR Moderator HQ
    Posts
    16,217
    Rep Power
    92

    Default Re: Did i just broke my laptop when installing RAM wrong?

    Chances are that you either damaged the connector, the motherboard, or both. What RAM (exactly) did you purchase? Did you check out the service manual for the laptop?

    Generally speaking, when you have to actually apply a lot of force when working on a computer something is terribly wrong.

    There is not much more that I can say, other than you most likely permanently damaged the computer. Could you post some pictures?
    Desktop   15" Macbook Pro Retina
    W7 Ultimate, Core i7 4770k, Crucial M500 240GB SSD   
    16GB RAM, GTX 780, 3x Dell U2412M Surround
       Mavericks, Core i7 4750HQ, 8GB RAM
       256GB SSD, 32GB iPad Air

  8. #18
    Notebook Geek
    Join Date
    Jun 2008
    Posts
    84
    Rep Power
    16

    Default Re: Did i just broke my laptop when installing RAM wrong?


  9. #19
    NBR Super Moderator
    Join Date
    Jul 2006
    Location
    NBR Moderator HQ
    Posts
    16,217
    Rep Power
    92

    Default Re: Did i just broke my laptop when installing RAM wrong?

    Quote Originally Posted by dynamic140 View Post
    That is the right kind of RAM alright, so it wasn't like you were trying to fit a square peg into a round hole. The force you put on the notebook had to have done it then.

    For images/pictures you can use actual HTML code, the IMG tag (kind of like the quote tag for NBR), or upload attachments by hitting the 'Advanced' button when you go to post.

    Take a look at this guide, it is one way to do it. (Link)
    Desktop   15" Macbook Pro Retina
    W7 Ultimate, Core i7 4770k, Crucial M500 240GB SSD   
    16GB RAM, GTX 780, 3x Dell U2412M Surround
       Mavericks, Core i7 4750HQ, 8GB RAM
       256GB SSD, 32GB iPad Air

  10. #20
    Notebook Evangelist
    Join Date
    May 2008
    Posts
    409
    Rep Power
    17

    Default Re: Did i just broke my laptop when installing RAM wrong?

    use photo bucket its quicker and free

 

 
Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 01:59 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1