Quantcast Base System Device problem (Inspiron 1420)

Closed Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Newbie
    Join Date
    Nov 2007
    Posts
    4
    Rep Power
    0

    Default Base System Device problem (Inspiron 1420)

    I hope I'm posting this in the right forum...

    I recently bought an Inspiron 1420 with Vista preinstalled. I was unhappy with the OS so I uninstalled it and put XP Professional on instead. I've gotten all my drivers back except for the Base System Device. A pop-up 'Found New Hardware' comes up every time I log on and won't go away, otherwise I would ignore this missing driver, since my computer is running fine without it.

    Can someone tell me where to get an XP compatible driver for this, or tell me if it is even necessary to have a 'Base System Device'? Can I just uninstall it?

    Thank you!

  2. #2
    Notebook Deity
    Join Date
    Apr 2007
    Posts
    1,711
    Rep Power
    25

    Default Re: Base System Device problem (Inspiron 1420)

    did you install drivers for the memory card reader?

  3. #3
    APH!
    Join Date
    Mar 2006
    Location
    Hetalia.
    Posts
    1,850
    Rep Power
    30

    Default Re: Base System Device problem (Inspiron 1420)

    You can always use Everest Home Edition [www.oldversion.com] - it's a freeware [It's discontinued, hence available at oldversion]. and it'll tell you everything about your hardware - maybe you can use that tool to see what exactly this "Base System Device" is.

  4. #4
    Newbie
    Join Date
    Nov 2007
    Posts
    4
    Rep Power
    0

    Default Re: Base System Device problem (Inspiron 1420)

    goofball- where can I look to find out which memory card reader my computer has?

    amol- thanks, I'll try that!

  5. #5
    Notebook Deity
    Join Date
    Apr 2007
    Posts
    1,711
    Rep Power
    25

    Default Re: Base System Device problem (Inspiron 1420)


  6. #6
    Newbie
    Join Date
    Nov 2007
    Posts
    4
    Rep Power
    0

    Default Re: Base System Device problem (Inspiron 1420)

    I tried the above link but it didn't work for me. It launches a new hardware installation wizard, and then it searches for device drivers but never finds any. I let it run for about an hour just to be sure, but it didn't make any progress.

  7. #7
    Notebook Virtuoso
    Join Date
    Feb 2007
    Location
    Inventing the piano key necktie.
    Posts
    3,621
    Rep Power
    37

    Default Re: Base System Device problem (Inspiron 1420)

    Just a question, did you install what Dell calls the Notebook System Software (chipset driver)? According to Dell Support Online, you needed to install this first to ensure the computer would work properly.
    More Info-
    Last edited by booboo12; 23rd November 2007 at 09:38 PM.
    Laptop/TabletPC : Dell Latitude D630/Venue 8 pro
    Phones: *lots of Windows Mobile phones* | Nexus 5

    PortableDigest.com mobile reviewer - writer
    "It's like the Ross of app stores" ~Storyoho on BlackBerry App World

  8. #8
    Newbie
    Join Date
    Nov 2007
    Posts
    4
    Rep Power
    0

    Default Re: Base System Device problem (Inspiron 1420)

    Yes, booboo12, I already have the chipset driver.

    Does anyone else have any suggestions? My computer seems to have been working fine despite the Base System Device not having its driver, but I'm really sick of the "Found New Hardware" wizard that pops up and won't go away every time I log on.

    Does anyone know if I can just erase the Base System Devices?

  9. #9
    Notebook Enthusiast
    Join Date
    Jun 2008
    Posts
    29
    Rep Power
    16

    Default Re: Base System Device problem (Inspiron 1420)

    Hi,
    I dont know if this reply is too late, but i have found the solution to this.
    Driver :

    http://supportapj.dell.com/support/d...&fileid=188377

    I too had 3 unknown Base System Device. When u install this driver, they will ask u if u want to replace ur old driver (dell touch pad, Modem). U can choose not to for these two device that u already know, but for the 3rd one, u must choose yes. That's when they ask u to install Ricoh Company (rimsptsk) hdc, u must press yes.

    Then u will have no more unknown base system. It works for me
    Dell Inspiron 1420 :
    -1.8G dual core. -2Gb 667M RAM. -8400M GS with 128 dedicated GDDR3 RAM and 384MB shared Memory. (oc 600/1600/750 powermizer disbaled) -160GB harddisk

  10. #10
    Newbie
    Join Date
    Dec 2008
    Posts
    1
    Rep Power
    0

    Default Re: Base System Device problem (Inspiron 1420)

    Dear
    I have problem same as bellow problem
    Quote Originally Posted by snowcaps View Post
    I hope I'm posting this in the right forum...

    I recently bought an Inspiron 1420 with Vista preinstalled. I was unhappy with the OS so I uninstalled it and put XP Professional on instead. I've gotten all my drivers back except for the Base System Device. A pop-up 'Found New Hardware' comes up every time I log on and won't go away, otherwise I would ignore this missing driver, since my computer is running fine without it.

    Can someone tell me where to get an XP compatible driver for this, or tell me if it is even necessary to have a 'Base System Device'? Can I just uninstall it?

    Thank you!

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 04:44 AM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1