Quantcast IDT audio says HDMI is unplugged

Closed Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Notebook Consultant
    Join Date
    Feb 2010
    Posts
    204
    Rep Power
    12

    Default IDT audio says HDMI is unplugged

    I cant get it back to plugged in when the cable is connected. The video transfers fine to the external monitor but I cant select the option to make the HDMI audio default audio device in the IDT control panel.

    I tried plugging and unplugging it with no luck. The only way to fix it as I can tell is to uninstall the HDMI audio driver from Catalyst and reinstall. I did not have any issue when I had the 4870 X fire system.

    What am I missing here?

    Thanks AWHW
    AW m17X__ I7_820__8_GIG'S_1333__2X_5870's__500_GIG__RGB_LED

  2. #2
    Notebook Enthusiast
    Join Date
    Jul 2010
    Posts
    13
    Rep Power
    11

    Default Re: IDT audio says HDMI is unplugged

    I experienced the same and here's what worked for me.

    1. Make sure the laptop is running on power and not on battery
    2. Connect the HDMI cable to the laptop and the external source.
    3. With it connected to both sources, restart the laptop.

    After following those steps, the HDMI audio was selected and if I plugged it in or out it would recognize that it was plugged in or not. It works now but the very first time I made the connection, I followed those steps.

  3. #3
    Notebook Consultant
    Join Date
    Feb 2010
    Posts
    204
    Rep Power
    12

    Default Re: IDT audio says HDMI is unplugged

    Thank You

    What I seems to be messing it up is using FN-F7 or FN-F6 instead of using created profiles in catalyst. I'm not sure about this but I think thats whats causing it for me. When I used these keys after posting the sound started to work. I will investigate more on this later.

    Another problem is that Windows sounds are delayed or just not working at all on the external display.
    AW m17X__ I7_820__8_GIG'S_1333__2X_5870's__500_GIG__RGB_LED

  4. #4
    Notebook Consultant
    Join Date
    Feb 2010
    Posts
    204
    Rep Power
    12

    Default Re: IDT audio says HDMI is unplugged

    Can't seem to pinpoint it yet.
    AW m17X__ I7_820__8_GIG'S_1333__2X_5870's__500_GIG__RGB_LED

  5. #5
    T|I
    Join Date
    Jan 2009
    Location
    out there
    Posts
    2,890
    Rep Power
    26

    Default Re: IDT audio says HDMI is unplugged

    what fixed it for me is installing this driver for hdmi :

    1. go to this link
    2. Click V on I Accept the above
    3. Download ATI HDMI Audio Device
    4. uninstall your current HDMI driver from device manager including the V on remove driver from machine
    5. Install the downloaded version
    6. Reboot

    Your HDMI connection will work every time.
    Tech|Inferno

    M18x Avenger :: i7 9720XM|18.4" 1920x1080 WLED|Dual ATI 7970m CF|Vertex III 240GB (Win 7) & Vertex III 120GB (LMDE)|8GB Kingston DDR3 1600MHz|Logitech MX

  6. #6
    Notebook Enthusiast
    Join Date
    Jul 2010
    Posts
    13
    Rep Power
    11

    Default Re: IDT audio says HDMI is unplugged

    Ok. My first suggestion stopped working for me.

    Here's what I did and is working for me now.

    1. I went into device manager > Sounds, video, and game controllers, Ati high definition audio device

    2. Right clicked on it and select "uninstall"

    3. Selected "delete the driver software for this device" and pressed ok

    4. Went back to the device manager, right clicked on "sound, video, and game controllers" and selected "scan for hardware changes". It found the device and I asked it to search for drivers for it. It installed a microsoft driver for the audio.

    5. With the older microsoft driver, it's working every time.

    Microsoft
    7/13/2009
    6.1.7600.16385
    Microsoft Windows

    The old driver that didn't work for me always was

    ATI Technologies Inc
    11/13/2009
    7.11.0.7700
    Microsoft Windows Hardware Compatibility Publisher

  7. #7
    T|I
    Join Date
    Jan 2009
    Location
    out there
    Posts
    2,890
    Rep Power
    26

    Default Re: IDT audio says HDMI is unplugged

    weird, for me the microsoft driver didn't work.
    Tech|Inferno

    M18x Avenger :: i7 9720XM|18.4" 1920x1080 WLED|Dual ATI 7970m CF|Vertex III 240GB (Win 7) & Vertex III 120GB (LMDE)|8GB Kingston DDR3 1600MHz|Logitech MX

  8. #8
    Notebook Enthusiast
    Join Date
    Sep 2010
    Posts
    23
    Rep Power
    10

    Default Re: IDT audio says HDMI is unplugged

    hy,

    I don't know if i have to open a new tread or if i can ask about my problem here since it's almost the same, the only difference is that it works fine and for no obvious reasons it stopped working and says HDMI is unplugged, if I reboot it's ok it works fine and again after a while it stopped working.

    I tried to do what you explain here but :

    - first i don't understand what you mean by "including the V on remove driver from machine", what is the V ?
    - i can't install those driver, i got an error msg, saying there is no driver on my computer who can handle those driver

    Quote Originally Posted by mfractal View Post
    what fixed it for me is installing this driver for hdmi :

    1. go to this link
    2. Click V on I Accept the above
    3. Download ATI HDMI Audio Device
    4. uninstall your current HDMI driver from device manager including the V on remove driver from machine
    5. Install the downloaded version
    6. Reboot

    Your HDMI connection will work every time.

  9. #9
    Big time Idiot
    Join Date
    Jan 2008
    Location
    Greater Sac, Cali
    Posts
    2,758
    Rep Power
    28

    Default Re: IDT audio says HDMI is unplugged

    V = checkmark
    Vaio SA 13.3" i5 + HD6630m
    8GB 128GB 1600x900

  10. #10
    Notebook Enthusiast
    Join Date
    Sep 2010
    Posts
    23
    Rep Power
    10

    Default Re: IDT audio says HDMI is unplugged

    oki thanks, but I still don't get it. the only option i got is uninstall/disabled/update, i don't see nothing who need to be "checkmark"


 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 04:06 AM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1