Quantcast Problem with "Activate Bluetooth Using Wireless Switch"

+ Reply to Thread
Page 1 of 4 1234 LastLast
Results 1 to 10 of 33
Like Tree1Likes

Thread: Problem with "Activate Bluetooth Using Wireless Switch"

  1. #1
    Newbie
    Join Date
    Aug 2009
    Posts
    5
    Rep Power
    14

    Default Problem with "Activate Bluetooth Using Wireless Switch"

    Hi there,

    Yesterday I did a clean install of Windows 7 Professional on my m11x system. The system came with Windows 7 Home Premium. The bluetooth in the system worked flawlessly prior to me doing a clean install of Windows. I spent 2 hours on the phone with a Dell rep last night, and neither he not I could figure out the problem. Every time I try to install the bluetooth drivers from the Dell website I get a message saying "activate bluetooth using wireless switch." In the device manager, the bluetooth icon shows a little yellow "!" over it. When I click the icon to check the device it says "device cannot start (code 10)." I am at a complete loss as to what the issue is. I have tried FN+F3 to put the wireless on and off, but that seems to do nothing. I uninstalled the drivers and reinstalled, checked the BIOS to ensure that bluetooth was activated and even booted into safe mode to install the drivers; nothing works. I am trying to avoid having a tech come out and do something to my computer when it seems that the issue is software related, as it worked prior to the clean install of Windows.

    If anyone has any suggestions at all, they would be greatly appreciated. I am going out of town in just over a week, so I am working on a very slim time table.

    Thanks for your time!

    Oblivion426
    Last edited by Oblivion426; 28th May 2010 at 08:31 AM.

  2. #2
    Floating in Space
    Join Date
    Jun 2009
    Location
    Mothership
    Posts
    1,577
    Rep Power
    20

    Default Re: Problem with "Activate Bluetooth Using Wireless Switch"

    Quote Originally Posted by Oblivion426 View Post
    Hi there,

    Yesterday I did a clean install of Windows 7 Professional on my m11x system. The system came with Windows 7 Home Premium. The bluetooth in the system worked flawlessly prior to me doing a clean install of Windows. I spent 2 hours on the phone with a Dell rep last night, and neither he not I could figure out the problem. Every time I try to install the bluetooth drivers from the Dell website I get a message saying "activate bluetooth using wireless switch." In the device manager, the bluetooth icon shows a little yellow "!" over it. When I click the icon to check the device it says "device cannot start (code 10)." I am at a complete loss as to what the issue is. I have tried FN+F3 to put the wireless on and off, but that seems to do nothing. I uninstalled the drivers and reinstalled, checked the BIOS to ensure that bluetooth was activated and even booted into safe mode to install the drivers; nothing works. I am trying to avoid having a tech come out and do something to my computer when it seems that the issue is software related, as it worked prior to the clean install of Windows.

    If anyone has any suggestions at all, they would be greatly appreciated. I am going out of town in just over a week, so I am working on a very slim time table.

    Thanks for your time!

    Oblivion426

    It seems like you have done the software side of things, the only thing i could suggest since I have seen it happen to my desktop , is open the laptop unplug the BT card, boot up then power down and put it back in and boot up.. I have seen this resolve this same issue on my desktop many times with the same error after reinstallation of software hasnt resolved....

    On a side note before physically removing it, did you uninstall the software, reboot into bios and switch it off, reboot to windows, then reboot to bios re-enable it, then reinstall it and see if that works?

    Service manual

    Documentation
    M17x Black R2
    920XM 8GB 1333MHz Mushkin WUXGA RGB LED ATI 4870 XF Intel 160GB x-25MG2 SSD BRay Intel Ult. N 6300
    Connected to External Samsung XL2370 RGB LED via HDMI

  3. #3
    Newbie
    Join Date
    Aug 2009
    Posts
    5
    Rep Power
    14

    Default Re: Problem with "Activate Bluetooth Using Wireless Switch"

    Last night on the phone with the Dell rep I took out the battery and held the power button down for 15 seconds and rebooted, but that did nothing. Your second suggestion I have not tried yet and will do so when I get home this afternoon.

    Thanks,

    Oblivion426

  4. #4
    Floating in Space
    Join Date
    Jun 2009
    Location
    Mothership
    Posts
    1,577
    Rep Power
    20

    Default Re: Problem with "Activate Bluetooth Using Wireless Switch"

    Just fyi, doing the battery trick is not the same as removing the BT card, booting and reseating it..
    M17x Black R2
    920XM 8GB 1333MHz Mushkin WUXGA RGB LED ATI 4870 XF Intel 160GB x-25MG2 SSD BRay Intel Ult. N 6300
    Connected to External Samsung XL2370 RGB LED via HDMI

  5. #5
    Newbie
    Join Date
    Aug 2009
    Posts
    5
    Rep Power
    14

    Default Re: Problem with "Activate Bluetooth Using Wireless Switch"

    Ah, misread what you stated. I will try taking out the BT card as a last resort. Trying to avoid opening the machine, since it really seems like a software issue since it was working just prior to me reinstalling Windows.

  6. #6
    Notebook Guru
    Join Date
    Apr 2009
    Posts
    63
    Rep Power
    14

    Default Re: Problem with "Activate Bluetooth Using Wireless Switch"

    It is very unlikely your hardware is broken if all you did was a fresh windows install.

    The device cannot start problem you describe is usually a driver issue

    Is there some kind of dell restore disk you can use to put it back the way it was and see if it works again?

    If it does I think you can upgrade win7 without installing in just a few minutes, check out Upgrade to another edition of Windows 7 by using Windows Anytime Upgrade
    M17X-R2 | i7 920XM

  7. #7
    Notebook Enthusiast
    Join Date
    Mar 2010
    Location
    Vancouver B.c.
    Posts
    15
    Rep Power
    12

    Default Re: Problem with "Activate Bluetooth Using Wireless Switch"

    I had this problem before. what i did to fix is was unzip the bluetooth drivers go to c:/ dell drivers instead of running setup install one of the packages and it will flash your bluetooth firmware and turn on your bluetooth again hope this helps. sorry can't give you details because i'm on my blackberry

    I'm gonna hop on my comp and give you a detailed step to fix this one second.
    Last edited by nguyenxhoang; 29th May 2010 at 08:33 PM.
    M15x Comic Black|i7-720|8GB 1333 DDR3|HyperXKingston 120gb SSD|Ati 6970m

  8. #8
    Notebook Enthusiast
    Join Date
    Mar 2010
    Location
    Vancouver B.c.
    Posts
    15
    Rep Power
    12

    Default Re: Problem with "Activate Bluetooth Using Wireless Switch"

    Okay I got it now.
    Step 1 : unzip dell bluetooth driver then exit installation.
    step 2 : go to c:/dell drivers folder
    step 3 : go to win64 and use installer in svcpack

    that should reinstall your bluetooth firmware and everything should work again. Hope this helps
    M15x Comic Black|i7-720|8GB 1333 DDR3|HyperXKingston 120gb SSD|Ati 6970m

  9. #9
    Notebook Consultant
    Join Date
    May 2010
    Posts
    193
    Rep Power
    12

    Default Re: Problem with "Activate Bluetooth Using Wireless Switch"

    Umm... press the wireless button on the top right side of the keyboard... its one of the touch sensative buttons. The wireless On/Off switch also controls the Bluetooth module.

  10. #10
    Newbie
    Join Date
    Aug 2009
    Posts
    5
    Rep Power
    14

    Default Re: Problem with "Activate Bluetooth Using Wireless Switch"

    nguyenxhoang,

    Thank you! Your fix resolved the problem. Flashing the firmware seemed to kick the Bluetooth back into gear. Thank you so much!!!!!

    Oblivion426

 

 
Page 1 of 4 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 04:50 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1