Quantcast The Aspire 5100 is dead. No power, no charging.

Closed Thread
Results 1 to 4 of 4
  1. #1
    Notebook Enthusiast
    Join Date
    Jun 2006
    Location
    Latvia
    Posts
    44
    Rep Power
    21

    Default The Aspire 5100 is dead. No power, no charging.

    It started with a faulty power cord with bad connection that resulted in interrupted power supply (after the slightest movement of the power cord computer showed the battery icon and the screen backlight dimmed - as if there was no power).

    I managed to deal with that just fine until the computer started a bad habbit of draining the battery and running out of juice when left ON overnight with the power cord connected. SOmehow it lost the power connection even when I didn't even touch it.

    I still didn't pay much attention to that until about a week ago it refused to turn on at all. It does not charge the battery, insted it makes a strange ticking noise, sometimes the charging light flashes sometimes it's constantly on, indicating that it's charging when it really isn't. Whith battery removed, it still won't turn on. It turns on for a split second and then it's off again, followed by that strange ticking sound.

    A opened it up, removed all the removable components from it (HDD, DVD drive, RAM, CPU FAN, battery) and still the same wierd behavior. The ticking sound comes from somwhere under the power button, I can't precisely locate it but it's pretty loud.

    As a computer it still works. I know that because when there was still a little reserve left in the battery it booted up until the Windows dektop before it ran out of juice. I think with a fully charged battery it would work 100% fine. But the problem is that laptop itself isn't charging the battery anymore and the AC is not provided directly to the system either. So I can't use it anyway.

    Some sort of power supply subsystem must be dead but I am afraid that it's integrated in the motherboard. And if that's the case, it would cost a fortune to replace.

    Do I have chances of cheap repair that does not involve replacement of motherboard?
    Lappy- Aspire 5100 (AMD Turion X2)
    Desk - AMD Athlon X2 5000+ 2.8 Ghz, 9800GT
    Desk2 - AMD Athlon XP 1900+, nVidia GeForce FX5200
    Desk3 - Celeron 500 Mhz 128 RAM.

  2. #2
    Vox Sola
    Join Date
    Mar 2007
    Posts
    1,293
    Rep Power
    24

    Default Re: The Aspire 5100 is dead. No power, no charging.

    If I remember my 5102 correctly there should be a pin in the same hole where the charger plugs into the notebook. Is this pin bent by any chance. If it is bent or broken you should probably try to solder it back on.

    If that pin isn't bent then there is a good possibility that your 5100 has a malfunctioning mainboard because the charging circuitry is damaged in someway and therefore is refusing to charge the battery or power the notebook.

    On most aspire 5100s once you get power problems it is usually something mainboard related and the only way to fix it is to replace the malfunctioning board.
    DELL Vostro 3550
    Intel Core i5-2410M @2.3GHz (Turbo boost 2.9GHz) | ATi Mobility Radeon HD 6630M 1GB | 6GB DDR3-1333| Samsung 830 256GB SSD |
    15.6" LED Display | Wifi b/g/n + Bluetooth 3.0 | Logitech M510 | Zalman NC1000 | Windows 7 Professional x64

  3. #3
    Notebook Enthusiast
    Join Date
    Feb 2009
    Location
    Scotland
    Posts
    15
    Rep Power
    14

    Default Re: The Aspire 5100 is dead. No power, no charging.

    Yeah your man is correct. Its defo a mainboard problem. there is a possiblity that ur laptop needs a power reset tho. so heres what to do, take ur battery out, put the plug (ac adapter) into the laptop and press and hold ur power button, while holding the button, remove the power cord and keep holding the powe button in for 10 seconds, then remove ur finger from the power button. plug the charger back into the laptop and wait 5 seconds then press the power button.

    If you get no activity after this, its a mainboard problem. Sending back to acer to get fixed is prob your best option if the power reset doesnt work.

    hold this helps and fixes the problem!

    New Guy in Town!!

  4. #4
    Newbie
    Join Date
    Apr 2009
    Posts
    1
    Rep Power
    0

    Default Re: The Aspire 5100 is dead. No power, no charging.

    I've had exactly the same problem with my Aspire 9500, i tried stripping down and resoldering the DC connection, i can measure 19v there but i still have the ticking and no power.

    RealAlert Did you manage to find a solution to the problem?
    Last edited by Deriko; 9th April 2009 at 01:09 PM. Reason: Addition of name

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 05:17 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1