Quantcast Aspire 5672 - No Power, No Lights, Nothing...

Closed Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Newbie
    Join Date
    Jun 2007
    Posts
    4
    Rep Power
    0

    Default Aspire 5672 - No Power, No Lights, Nothing...

    I was watching a movie on my Aspire laptop yesterday when the application just exited and I watched as my laptop slowly went black. Once it was completely powered off, I tried to turn it back on but pressing the power button did nothing. I unplugged it (it was plugged in at the time) and resettled the battery, but still no power gets through. When plugged in to the adapter, the lights on the front do not light up, and strangely when I plug it into the adapter, the adapter led goes from a solid green to a flashing green (same with the battery out and adapter in). What does this mean? Is the power supply dead? Did something fry? Of course I'm fresh out of warranty and am in the process of buying an extended warranty. Has anyone else had this problem?

  2. #2
    Notebook Evangelist
    Join Date
    Jun 2007
    Location
    Right Behind You
    Posts
    389
    Rep Power
    19

    Default Re: Aspire 5672 - No Power, No Lights, Nothing...

    Have you tried letting it sit and cool down, it may have gotten overheated?

    Asus G1S--Vista HP 64-bit : 4GB RAM : T7500 : nVidia 8600M GT

  3. #3
    Newbie
    Join Date
    Jun 2007
    Posts
    4
    Rep Power
    0

    Default Re: Aspire 5672 - No Power, No Lights, Nothing...

    I let it cool down overnight. It's in the same state today.

  4. #4
    old boy
    Join Date
    May 2007
    Location
    Essex,England
    Posts
    1,626
    Rep Power
    24

    Default Re: Aspire 5672 - No Power, No Lights, Nothing...

    can you test the power cable..it should read 19v DC.?

    if thats ok and the battery is charged.sounds internal.

  5. #5
    Notebook Evangelist
    Join Date
    Jun 2007
    Location
    Right Behind You
    Posts
    389
    Rep Power
    19

    Default Re: Aspire 5672 - No Power, No Lights, Nothing...

    Quote Originally Posted by hoggie View Post
    can you test the power cable..it should read 19v DC.?

    if thats ok and the battery is charged.sounds internal.
    Acer34e, do you know how to do that?

    Asus G1S--Vista HP 64-bit : 4GB RAM : T7500 : nVidia 8600M GT

  6. #6
    old boy
    Join Date
    May 2007
    Location
    Essex,England
    Posts
    1,626
    Rep Power
    24

    Default Re: Aspire 5672 - No Power, No Lights, Nothing...

    Quote Originally Posted by LiveDesign View Post
    Acer34e, do you know how to do that?
    sorry my fault.you will need a test meter.

  7. #7
    Newbie
    Join Date
    Jun 2007
    Posts
    4
    Rep Power
    0

    Default Re: Aspire 5672 - No Power, No Lights, Nothing...

    Too funny. Yes I tested the power cord and it's good. I guess something internal is fried. I saw somebody with this same problem on a different forum, but there was never a resolution posted. Hopefully I can get it figured out soon and post the verdict.

  8. #8
    Notebook Deity
    Join Date
    Jun 2006
    Location
    Courtenay
    Posts
    1,690
    Rep Power
    27

    Default Re: Aspire 5672 - No Power, No Lights, Nothing...

    Is this notebook under warrenty or not?

    if not i say rip it down see if you can figure out why it will not posted


    Or sell it for parts :>

    I sure me and many other fourm members might want some parts :>
    New Aspire one Sub Notebook
    New Ibm X61T 776295U
    Sold Acer Aspire 5672

  9. #9
    old boy
    Join Date
    May 2007
    Location
    Essex,England
    Posts
    1,626
    Rep Power
    24

    Default Re: Aspire 5672 - No Power, No Lights, Nothing...

    right think i found one answer.the centre post in the power socket had come away from the board, was one.
    and try starting the laptop with the battery removed.
    if you have already tried this.then im lost

  10. #10
    Newbie
    Join Date
    Feb 2006
    Posts
    9
    Rep Power
    21

    Default Re: Aspire 5672 - No Power, No Lights, Nothing...

    Hi - I realize this thread is pretty old - has anyone ever found a solution to this problem? My 5672 - 3 days out of warranty is doing the exact same thing. Won't power on with battery or not, and when plugged in the power supply flashes. It's a solid when it's disconnected. I figured I'd try the forums before opening it up and cleaning / reseating everything. Thanks!

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Aspire 5633 - lights blink, won't boot
    By ma701ss in forum Acer
    Replies: 3
    Last Post: 13th June 2008, 03:39 PM
  2. need aspire 5672 wallpaper
    By behnam sarfaraz in forum Acer
    Replies: 1
    Last Post: 12th September 2006, 10:06 PM
  3. NEW Taiwan Aspire 5672 VS. US Aspire 5672
    By kamikazex in forum Acer
    Replies: 10
    Last Post: 12th August 2006, 10:30 PM
  4. Replies: 2
    Last Post: 9th June 2006, 07:44 AM
  5. Aspire 5672?
    By sctv in forum Acer
    Replies: 0
    Last Post: 19th April 2006, 05:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 03:26 AM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1